Generate a pkg-config file for Folly
[folly.git] / folly / Makefile.am
index 912e117be2a3adb71c25aabfe6639f38f93ba8d1..1352e2bef8b0e6ccf1a022f22a89e07b7ee26169 100644 (file)
@@ -63,6 +63,7 @@ nobase_follyinclude_HEADERS = \
        detail/Futex.h \
        detail/GroupVarintDetail.h \
        detail/IPAddress.h \
+       detail/IPAddressSource.h \
        detail/Malloc.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
@@ -70,6 +71,7 @@ nobase_follyinclude_HEADERS = \
        detail/RangeSse42.h \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
+       detail/SocketFastOpen.h \
        detail/SpinLockImpl.h \
        detail/StaticSingletonManager.h \
        detail/Stats.h \
@@ -81,10 +83,13 @@ nobase_follyinclude_HEADERS = \
        DynamicConverter.h \
        dynamic.h \
        dynamic-inl.h \
+       Enumerate.h \
        Exception.h \
+       ExceptionString.h \
        ExceptionWrapper.h \
        Executor.h \
        EvictingCacheMap.h \
+       experimental/AsymmetricMemoryBarrier.h \
        experimental/AutoTimer.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
@@ -95,32 +100,6 @@ nobase_follyinclude_HEADERS = \
        experimental/EventCount.h \
        experimental/Instructions.h \
        experimental/bser/Bser.h \
-       experimental/fibers/AddTasks.h \
-       experimental/fibers/AddTasks-inl.h \
-       experimental/fibers/Baton.h \
-       experimental/fibers/Baton-inl.h \
-       experimental/fibers/BoostContextCompatibility.h \
-       experimental/fibers/EventBaseLoopController.h \
-       experimental/fibers/EventBaseLoopController-inl.h \
-       experimental/fibers/Fiber.h \
-       experimental/fibers/Fiber-inl.h \
-       experimental/fibers/FiberManager.h \
-       experimental/fibers/FiberManager-inl.h \
-       experimental/fibers/FiberManagerMap.h \
-       experimental/fibers/ForEach.h \
-       experimental/fibers/ForEach-inl.h \
-       experimental/fibers/GenericBaton.h \
-       experimental/fibers/GuardPageAllocator.h \
-       experimental/fibers/LoopController.h \
-       experimental/fibers/Promise.h \
-       experimental/fibers/Promise-inl.h \
-       experimental/fibers/SimpleLoopController.h \
-       experimental/fibers/TimedMutex.h \
-       experimental/fibers/TimedMutex-inl.h \
-       experimental/fibers/TimeoutController.h \
-       experimental/fibers/traits.h \
-       experimental/fibers/WhenN.h \
-       experimental/fibers/WhenN-inl.h \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
@@ -155,7 +134,6 @@ nobase_follyinclude_HEADERS = \
        Format.h \
        Format-inl.h \
        futures/Barrier.h \
-       futures/ThreadedExecutor.h \
        futures/DrivableExecutor.h \
        futures/Future-pre.h \
        futures/helpers.h \
@@ -173,9 +151,6 @@ nobase_follyinclude_HEADERS = \
        futures/SharedPromise-inl.h \
        futures/ThreadWheelTimekeeper.h \
        futures/Timekeeper.h \
-       futures/Try-inl.h \
-       futures/Try.h \
-       futures/Unit.h \
        futures/detail/Core.h \
        futures/detail/FSM.h \
        futures/detail/Types.h \
@@ -205,6 +180,7 @@ nobase_follyinclude_HEADERS = \
        IntrusiveList.h \
        io/Compression.h \
        io/Cursor.h \
+       io/Cursor-inl.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
        io/RecordIO.h \
@@ -222,6 +198,7 @@ nobase_follyinclude_HEADERS = \
        io/async/AsyncSocketBase.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
+       io/async/DecoratedAsyncTransportWrapper.h \
        io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
        io/async/EventBase.h \
@@ -240,6 +217,7 @@ nobase_follyinclude_HEADERS = \
        io/async/SSLContext.h \
        io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
+       io/async/WriteChainAsyncTransportWrapper.h \
        io/async/test/AsyncSSLSocketTest.h \
        io/async/test/BlockingSocket.h \
        io/async/test/MockAsyncSocket.h \
@@ -256,6 +234,8 @@ nobase_follyinclude_HEADERS = \
        Lazy.h \
        LifoSem.h \
        Likely.h \
+       LockTraits.h \
+       LockTraitsBoost.h \
        Logging.h \
        MacAddress.h \
        Malloc.h \
@@ -273,23 +253,28 @@ nobase_follyinclude_HEADERS = \
        PicoSpinLock.h \
        Portability.h \
        portability/Asm.h \
+       portability/Atomic.h \
        portability/Builtins.h \
        portability/Config.h \
        portability/Constexpr.h \
        portability/Dirent.h \
        portability/Environment.h \
+       portability/Event.h \
        portability/Fcntl.h \
        portability/GFlags.h \
        portability/IOVec.h \
        portability/Libgen.h \
        portability/Malloc.h \
+       portability/Math.h \
        portability/Memory.h \
        portability/PThread.h \
        portability/Sockets.h \
+       portability/Stdio.h \
        portability/Stdlib.h \
        portability/String.h \
        portability/Syslog.h \
        portability/SysFile.h \
+       portability/SysMembarrier.h \
        portability/SysMman.h \
        portability/SysResource.h \
        portability/SysStat.h \
@@ -299,6 +284,7 @@ nobase_follyinclude_HEADERS = \
        portability/SysUio.h \
        portability/Time.h \
        portability/Windows.h \
+       portability/Unistd.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -318,6 +304,7 @@ nobase_follyinclude_HEADERS = \
        SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
+       ssl/OpenSSLHash.h \
        stats/BucketedTimeSeries-defs.h \
        stats/BucketedTimeSeries.h \
        stats/Histogram-defs.h \
@@ -326,6 +313,7 @@ nobase_follyinclude_HEADERS = \
        stats/MultiLevelTimeSeries.h \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
+       stop_watch.h \
        String.h \
        String-inl.h \
        Subprocess.h \
@@ -343,8 +331,11 @@ nobase_follyinclude_HEADERS = \
        ThreadName.h \
        TimeoutQueue.h \
        Traits.h \
+       Try-inl.h \
+       Try.h \
        Unicode.h \
        Function.h \
+       Unit.h \
        Uri.h \
        Uri-inl.h \
        Varint.h \
@@ -378,12 +369,12 @@ libfolly_la_SOURCES = \
        Bits.cpp \
        Checksum.cpp \
        detail/CacheLocality.cpp \
+       detail/IPAddress.cpp \
        dynamic.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
-       futures/ThreadedExecutor.cpp \
        futures/Future.cpp \
        futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
@@ -399,6 +390,7 @@ libfolly_la_SOURCES = \
        IPAddressV6.cpp \
        LifoSem.cpp \
        io/Compression.cpp \
+       io/Cursor.cpp \
        io/IOBuf.cpp \
        io/IOBufQueue.cpp \
        io/RecordIO.cpp \
@@ -424,6 +416,7 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
+       detail/SocketFastOpen.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
        portability/Dirent.cpp \
@@ -433,14 +426,18 @@ libfolly_la_SOURCES = \
        portability/Malloc.cpp \
        portability/Memory.cpp \
        portability/Sockets.cpp \
+       portability/Stdio.cpp \
        portability/Stdlib.cpp \
        portability/String.cpp \
        portability/SysFile.cpp \
+       portability/SysMembarrier.cpp \
        portability/SysMman.cpp \
        portability/SysResource.cpp \
        portability/SysStat.cpp \
        portability/SysTime.cpp \
+       portability/SysUio.cpp \
        portability/Time.cpp \
+       portability/Unistd.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \
@@ -449,21 +446,17 @@ libfolly_la_SOURCES = \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
+       ssl/OpenSSLHash.cpp \
        stats/Instantiations.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
+       experimental/AsymmetricMemoryBarrier.cpp \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
-       experimental/fibers/Baton.cpp \
-       experimental/fibers/Fiber.cpp \
-       experimental/fibers/FiberManager.cpp \
-       experimental/fibers/FiberManagerMap.cpp \
-       experimental/fibers/GuardPageAllocator.cpp \
-       experimental/fibers/TimeoutController.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
        experimental/JSONSchema.cpp \
@@ -487,6 +480,44 @@ if !HAVE_BITS_FUNCTEXCEPT_H
 libfollybase_la_SOURCES += detail/FunctionalExcept.cpp
 endif
 
+if HAVE_BOOST_CONTEXT
+nobase_follyinclude_HEADERS += \
+       fibers/AddTasks.h \
+       fibers/AddTasks-inl.h \
+       fibers/Baton.h \
+       fibers/Baton-inl.h \
+       fibers/BoostContextCompatibility.h \
+       fibers/EventBaseLoopController.h \
+       fibers/EventBaseLoopController-inl.h \
+       fibers/Fiber.h \
+       fibers/Fiber-inl.h \
+       fibers/FiberManager.h \
+       fibers/FiberManager-inl.h \
+       fibers/FiberManagerMap.h \
+       fibers/ForEach.h \
+       fibers/ForEach-inl.h \
+       fibers/GenericBaton.h \
+       fibers/GuardPageAllocator.h \
+       fibers/LoopController.h \
+       fibers/Promise.h \
+       fibers/Promise-inl.h \
+       fibers/SimpleLoopController.h \
+       fibers/TimedMutex.h \
+       fibers/TimedMutex-inl.h \
+       fibers/TimeoutController.h \
+       fibers/traits.h \
+       fibers/WhenN.h \
+       fibers/WhenN-inl.h
+
+libfolly_la_SOURCES += \
+       fibers/Baton.cpp \
+       fibers/Fiber.cpp \
+       fibers/FiberManager.cpp \
+       fibers/FiberManagerMap.cpp \
+       fibers/GuardPageAllocator.cpp \
+       fibers/TimeoutController.cpp
+endif
+
 libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 
 libfolly_la_LIBADD = libfollybase.la
@@ -499,3 +530,7 @@ CLEANFILES += FingerprintTables.cpp
 libfollybenchmark_la_SOURCES = Benchmark.cpp
 libfollybenchmark_la_LIBADD = libfolly.la
 libfollybenchmark_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
+
+# install pkg-config metadata file
+pkgconfigdir = $(libdir)/pkgconfig
+nodist_pkgconfig_DATA = libfolly.pc