Create the portability header for time.h
[folly.git] / folly / Makefile.am
index ddef486a9a476f3ff9d6af2a6995e4eda02d6c43..0dc1d29e44bb0f6511f75d9ad49abf4fe4bf681a 100644 (file)
@@ -70,6 +70,7 @@ nobase_follyinclude_HEADERS = \
        detail/Sleeper.h \
        detail/SlowFingerprint.h \
        detail/SpinLockImpl.h \
+       detail/StaticSingletonManager.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
        detail/TurnSequencer.h \
@@ -195,6 +196,7 @@ nobase_follyinclude_HEADERS = \
        IPAddressV4.h \
        IPAddressV6.h \
        IPAddressException.h \
+       Indestructible.h \
        IndexedMemPool.h \
        init/Init.h \
        IntrusiveList.h \
@@ -264,8 +266,12 @@ nobase_follyinclude_HEADERS = \
        PicoSpinLock.h \
        Portability.h \
        portability/Constexpr.h \
+       portability/Environment.h \
+       portability/GFlags.h \
        portability/Syscall.h \
+       portability/SysTime.h \
        portability/SysUio.h \
+       portability/Time.h \
        Preprocessor.h \
        ProducerConsumerQueue.h \
        Random.h \
@@ -356,6 +362,7 @@ libfolly_la_SOURCES = \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \
        detail/Futex.cpp \
+       detail/StaticSingletonManager.cpp \
        detail/ThreadLocalDetail.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -379,6 +386,7 @@ libfolly_la_SOURCES = \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
+       io/async/Request.cpp \
        io/async/SSLContext.cpp \
        io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
@@ -388,6 +396,9 @@ libfolly_la_SOURCES = \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
+       portability/Environment.cpp \
+       portability/SysTime.cpp \
+       portability/Time.cpp \
        Random.cpp \
        SafeAssert.cpp \
        SharedMutex.cpp \