apply clang-tidy modernize-use-override
[folly.git] / folly / Makefile.am
index 1ffd730483c540eed6d87c9b6de6effb5259753f..0b1a10d71abf2d7adb577a749da365b63ab4359e 100644 (file)
@@ -58,11 +58,11 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CoreCachedSharedPtr.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
        detail/BitIteratorDetail.h \
-       detail/BitsDetail.h \
        detail/CacheLocality.h \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
@@ -73,7 +73,7 @@ nobase_follyinclude_HEADERS = \
        detail/GroupVarintDetail.h \
        detail/IPAddress.h \
        detail/IPAddressSource.h \
-       detail/Malloc.h \
+       detail/MallocImpl.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/RangeCommon.h \
@@ -149,6 +149,7 @@ nobase_follyinclude_HEADERS = \
        experimental/symbolizer/StackTrace.h \
        experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
+       experimental/StampedPtr.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedMap.h \
        experimental/StringKeyedSet.h \
@@ -239,6 +240,7 @@ nobase_follyinclude_HEADERS = \
        io/async/DecoratedAsyncTransportWrapper.h \
        io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
+       io/async/DestructorCheck.h \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
@@ -287,6 +289,7 @@ nobase_follyinclude_HEADERS = \
        Math.h \
        Memory.h \
        MemoryMapping.h \
+       memory/UninitializedMemoryHacks.h \
        MicroSpinLock.h \
        MicroLock.h \
        MoveWrapper.h \
@@ -334,8 +337,8 @@ nobase_follyinclude_HEADERS = \
        portability/SysUio.h \
        portability/Time.h \
        portability/TypeTraits.h \
-       portability/Windows.h \
        portability/Unistd.h \
+       portability/Windows.h \
        Preprocessor.h \
        PriorityMPMCQueue.h \
        ProducerConsumerQueue.h \
@@ -437,7 +440,6 @@ libfollybase_la_SOURCES = \
 
 libfolly_la_SOURCES = \
        Assume.cpp \
-       Bits.cpp \
        Checksum.cpp \
        ClockGettimeWrappers.cpp \
        detail/CacheLocality.cpp \
@@ -450,7 +452,6 @@ libfolly_la_SOURCES = \
        FingerprintTables.cpp \
        futures/Barrier.cpp \
        futures/Future.cpp \
-       futures/InlineExecutor.cpp \
        futures/ManualExecutor.cpp \
        futures/QueuedImmediateExecutor.cpp \
        futures/ThreadWheelTimekeeper.cpp \