folly: support FOLLY_FALLTHROUGH on GCC
[folly.git] / folly / Makefile.am
index 422b7bb872f7416f060617e387714d5875549cfa..0639ff90b7f388f03701ba2660a5db61e3dd2fd9 100644 (file)
@@ -56,6 +56,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       container/Access.h \
        container/Array.h \
        container/Iterator.h \
        container/Enumerate.h \
@@ -313,6 +314,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/Util.h \
        json.h \
        lang/Assume.h \
+       lang/ColdClass.h \
        lang/Launder.h \
        lang/RValueReferenceWrapper.h \
        lang/SafeAssert.h \
@@ -566,6 +568,7 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        lang/Assume.cpp \
+       lang/ColdClass.cpp \
        lang/SafeAssert.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \