folly: support FOLLY_FALLTHROUGH on GCC
[folly.git] / folly / Makefile.am
index 337b1cd6d351c82155836f25f5a91e9c57f6d0c6..0639ff90b7f388f03701ba2660a5db61e3dd2fd9 100644 (file)
@@ -45,7 +45,6 @@ nobase_follyinclude_HEADERS = \
        ClockGettimeWrappers.h \
        ConcurrentSkipList.h \
        ConcurrentSkipList-inl.h \
-       ContainerTraits.h \
        Conv.h \
        CppAttributes.h \
        CpuId.h \
@@ -57,6 +56,7 @@ nobase_follyinclude_HEADERS = \
        concurrency/ConcurrentHashMap.h \
        concurrency/CoreCachedSharedPtr.h \
        concurrency/detail/ConcurrentHashMap-detail.h \
+       container/Access.h \
        container/Array.h \
        container/Iterator.h \
        container/Enumerate.h \
@@ -77,6 +77,7 @@ nobase_follyinclude_HEADERS = \
        detail/IPAddressSource.h \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
+       detail/PolyDetail.h \
        detail/RangeCommon.h \
        detail/RangeSse42.h \
        detail/Sleeper.h \
@@ -84,6 +85,7 @@ nobase_follyinclude_HEADERS = \
        detail/SocketFastOpen.h \
        detail/StaticSingletonManager.h \
        detail/ThreadLocalDetail.h \
+       detail/TypeList.h \
        detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        executors/Async.h \
@@ -124,7 +126,6 @@ nobase_follyinclude_HEADERS = \
        Expected.h \
        concurrency/AtomicSharedPtr.h \
        concurrency/detail/AtomicSharedPtr-detail.h \
-       experimental/AsymmetricMemoryBarrier.h \
        experimental/AutoTimer.h \
        experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
@@ -313,9 +314,11 @@ nobase_follyinclude_HEADERS = \
        io/async/test/Util.h \
        json.h \
        lang/Assume.h \
+       lang/ColdClass.h \
        lang/Launder.h \
+       lang/RValueReferenceWrapper.h \
+       lang/SafeAssert.h \
        Lazy.h \
-       LifoSem.h \
        Likely.h \
        LockTraits.h \
        LockTraitsBoost.h \
@@ -341,6 +344,10 @@ nobase_follyinclude_HEADERS = \
        PackedSyncPtr.h \
        Padded.h \
        PicoSpinLock.h \
+       Poly.h \
+       Poly-inl.h \
+       poly/Nullable.h \
+       poly/Regular.h \
        Portability.h \
        portability/Asm.h \
        portability/Atomic.h \
@@ -388,7 +395,6 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        Replaceable.h \
        RWSpinLock.h \
-       SafeAssert.h \
        ScopeGuard.h \
        SharedMutex.h \
        Singleton.h \
@@ -417,7 +423,9 @@ nobase_follyinclude_HEADERS = \
        stats/MultiLevelTimeSeries.h \
        stats/TimeseriesHistogram-defs.h \
        stats/TimeseriesHistogram.h \
+       synchronization/AsymmetricMemoryBarrier.h \
        synchronization/CallOnce.h \
+       synchronization/LifoSem.h \
        synchronization/detail/AtomicUtils.h \
        system/MemoryMapping.h \
        system/Shell.h \
@@ -448,7 +456,6 @@ nobase_follyinclude_HEADERS = \
        Try.h \
        Unicode.h \
        Function.h \
-       Functional.h \
        UncaughtExceptions.h \
        Unit.h \
        Uri.h \
@@ -498,6 +505,7 @@ libfolly_la_SOURCES = \
        dynamic.cpp \
        ExceptionWrapper.cpp \
        Executor.cpp \
+       Expected.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
@@ -527,7 +535,6 @@ libfolly_la_SOURCES = \
        IPAddress.cpp \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
-       LifoSem.cpp \
        init/Init.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -561,6 +568,8 @@ libfolly_la_SOURCES = \
        io/async/ssl/SSLErrors.cpp \
        json.cpp \
        lang/Assume.cpp \
+       lang/ColdClass.cpp \
+       lang/SafeAssert.cpp \
        detail/MemoryIdler.cpp \
        detail/SocketFastOpen.cpp \
        MacAddress.cpp \
@@ -586,7 +595,6 @@ libfolly_la_SOURCES = \
        portability/Time.cpp \
        portability/Unistd.cpp \
        Random.cpp \
-       SafeAssert.cpp \
        ScopeGuard.cpp \
        SharedMutex.cpp \
        MicroLock.cpp \
@@ -602,6 +610,8 @@ libfolly_la_SOURCES = \
        stats/Histogram.cpp \
        stats/MultiLevelTimeSeries.cpp \
        stats/TimeseriesHistogram.cpp \
+       synchronization/AsymmetricMemoryBarrier.cpp \
+       synchronization/LifoSem.cpp \
        system/MemoryMapping.cpp \
        system/Shell.cpp \
        system/ThreadName.cpp \
@@ -610,7 +620,6 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Try.cpp \
        Uri.cpp \
-       experimental/AsymmetricMemoryBarrier.cpp \
        experimental/ThreadedRepeatingFunctionRunner.cpp \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
@@ -706,6 +715,11 @@ libfolly_la_SOURCES += \
        experimental/symbolizer/Symbolizer.cpp
 endif
 
+if HAVE_VARIABLE_TEMPLATES
+libfolly_la_SOURCES += \
+       Poly.cpp
+endif
+
 libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
 libfollybasesse42_la_CXXFLAGS = -msse4.2 -mpclmul