folly/wangle -> wangle cutover
[folly.git] / folly / Makefile.am
index a95e558c9473a2dc48aed6efe268bd92689eccf9..0401ce6b1fb3c1c71de8fdba55447621f558b568 100644 (file)
@@ -26,7 +26,9 @@ nobase_follyinclude_HEADERS = \
        AtomicHashArray-inl.h \
        AtomicHashMap.h \
        AtomicHashMap-inl.h \
+       AtomicLinkedList.h \
        AtomicStruct.h \
+       AtomicUnorderedMap.h \
        Baton.h \
        Benchmark.h \
        Bits.h \
@@ -38,6 +40,7 @@ nobase_follyinclude_HEADERS = \
        CpuId.h \
        CPortability.h \
        detail/AtomicHashUtils.h \
+       detail/AtomicUnorderedMapUtils.h \
        detail/BitIteratorDetail.h \
        detail/BitsDetail.h \
        detail/CacheLocality.h \
@@ -55,8 +58,10 @@ nobase_follyinclude_HEADERS = \
        detail/MemoryIdler.h \
        detail/MPMCPipelineDetail.h \
        detail/SlowFingerprint.h \
+       detail/SpinLockImpl.h \
        detail/Stats.h \
        detail/ThreadLocalDetail.h \
+       detail/TurnSequencer.h \
        detail/UncaughtExceptionCounter.h \
        Demangle.h \
        DiscriminatedPtr.h \
@@ -65,29 +70,52 @@ nobase_follyinclude_HEADERS = \
        dynamic-inl.h \
        Exception.h \
        ExceptionWrapper.h \
+       Executor.h \
        EvictingCacheMap.h \
+       experimental/AutoTimer.h \
        experimental/Bits.h \
+       experimental/BitVectorCoding.h \
+       experimental/ExecutionObserver.h \
        experimental/EliasFanoCoding.h \
        experimental/EventCount.h \
+       experimental/Instructions.h \
+       experimental/fibers/AddTasks.h \
+       experimental/fibers/AddTasks-inl.h \
+       experimental/fibers/Baton.h \
+       experimental/fibers/Baton-inl.h \
+       experimental/fibers/BoostContextCompatibility.h \
+       experimental/fibers/EventBaseLoopController.h \
+       experimental/fibers/EventBaseLoopController-inl.h \
+       experimental/fibers/Fiber.h \
+       experimental/fibers/Fiber-inl.h \
+       experimental/fibers/FiberManager.h \
+       experimental/fibers/FiberManager-inl.h \
+       experimental/fibers/FiberManagerMap.h \
+       experimental/fibers/ForEach.h \
+       experimental/fibers/ForEach-inl.h \
+       experimental/fibers/GenericBaton.h \
+       experimental/fibers/GuardPageAllocator.h \
+       experimental/fibers/LoopController.h \
+       experimental/fibers/Promise.h \
+       experimental/fibers/Promise-inl.h \
+       experimental/fibers/SimpleLoopController.h \
+       experimental/fibers/TimedMutex.h \
+       experimental/fibers/TimedMutex-inl.h \
+       experimental/fibers/TimeoutController.h \
+       experimental/fibers/traits.h \
+       experimental/fibers/WhenN.h \
+       experimental/fibers/WhenN-inl.h \
+       experimental/FunctionScheduler.h \
+       experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
-       experimental/Singleton.h \
+       experimental/JSONSchema.h \
+       experimental/LockFreeRingBuffer.h \
+       experimental/Select64.h \
+       experimental/StringKeyedCommon.h \
+       experimental/StringKeyedUnorderedMap.h \
+       experimental/StringKeyedUnorderedSet.h \
        experimental/TestUtil.h \
-       experimental/wangle/concurrent/BlockingQueue.h \
-       experimental/wangle/concurrent/Codel.h \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.h \
-       experimental/wangle/concurrent/FutureExecutor.h \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.h \
-       experimental/wangle/concurrent/LifoSemMPMCQueue.h \
-       experimental/wangle/concurrent/NamedThreadFactory.h \
-       experimental/wangle/concurrent/ThreadFactory.h \
-       experimental/wangle/concurrent/ThreadPoolExecutor.h \
-       experimental/wangle/rx/Observable.h \
-       experimental/wangle/rx/Observer.h \
-       experimental/wangle/rx/Subject.h \
-       experimental/wangle/rx/Subscription.h \
-       experimental/wangle/rx/types.h \
-       experimental/wangle/ConnectionManager.h \
-       experimental/wangle/ManagedConnection.h \
+       experimental/TupleOps.h \
        FBString.h \
        FBVector.h \
        File.h \
@@ -96,8 +124,33 @@ nobase_follyinclude_HEADERS = \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
+       FormatTraits.h \
        Format.h \
        Format-inl.h \
+       futures/Deprecated.h \
+       futures/DrivableExecutor.h \
+       futures/Future-pre.h \
+       futures/helpers.h \
+       futures/Future.h \
+       futures/Future-inl.h \
+       futures/FutureException.h \
+       futures/InlineExecutor.h \
+       futures/ManualExecutor.h \
+       futures/OpaqueCallbackShunt.h \
+       futures/Promise-inl.h \
+       futures/Promise.h \
+       futures/QueuedImmediateExecutor.h \
+       futures/ScheduledExecutor.h \
+       futures/SharedPromise.h \
+       futures/SharedPromise-inl.h \
+       futures/Timekeeper.h \
+       futures/Try-inl.h \
+       futures/Try.h \
+       futures/Unit.h \
+       futures/detail/Core.h \
+       futures/detail/FSM.h \
+       futures/detail/ThreadWheelTimekeeper.h \
+       futures/detail/Types.h \
        gen/Base.h \
        gen/Base-inl.h \
        gen/Combine.h \
@@ -124,16 +177,18 @@ nobase_follyinclude_HEADERS = \
        io/Cursor.h \
        io/IOBuf.h \
        io/IOBufQueue.h \
-       io/PortableSpinLock.h \
        io/RecordIO.h \
        io/RecordIO-inl.h \
        io/TypedIOBuf.h \
        io/ShutdownSocketSet.h \
        io/async/AsyncTimeout.h \
        io/async/AsyncTransport.h \
+       io/async/AsyncUDPServerSocket.h \
+       io/async/AsyncUDPSocket.h \
        io/async/AsyncServerSocket.h \
-       io/async/AsyncSSLServerSocket.h \
+       io/async/AsyncSignalHandler.h \
        io/async/AsyncSocket.h \
+       io/async/AsyncSocketBase.h \
        io/async/AsyncSSLSocket.h \
        io/async/AsyncSocketException.h \
        io/async/DelayedDestruction.h \
@@ -146,7 +201,17 @@ nobase_follyinclude_HEADERS = \
        io/async/HHWheelTimer.h \
        io/async/Request.h \
        io/async/SSLContext.h \
+       io/async/ScopedEventBaseThread.h \
        io/async/TimeoutManager.h \
+       io/async/test/AsyncSSLSocketTest.h \
+       io/async/test/BlockingSocket.h \
+       io/async/test/MockAsyncSocket.h \
+       io/async/test/MockAsyncServerSocket.h \
+       io/async/test/MockAsyncSSLSocket.h \
+       io/async/test/MockAsyncTransport.h \
+       io/async/test/TimeUtil.h \
+       io/async/test/UndelayedDestruction.h \
+       io/async/test/Util.h \
        json.h \
        Lazy.h \
        LifoSem.h \
@@ -171,10 +236,14 @@ nobase_follyinclude_HEADERS = \
        Range.h \
        RWSpinLock.h \
        ScopeGuard.h \
+       SharedMutex.h \
+       Singleton.h \
+       Singleton-inl.h \
        SmallLocks.h \
        small_vector.h \
        SocketAddress.h \
        sorted_vector_types.h \
+       SpinLock.h \
        SpookyHashV1.h \
        SpookyHashV2.h \
        stats/BucketedTimeSeries-defs.h \
@@ -203,36 +272,18 @@ nobase_follyinclude_HEADERS = \
        Uri.h \
        Uri-inl.h \
        Varint.h \
-       VersionCheck.h \
-       wangle/Deprecated.h \
-       wangle/Executor.h \
-       wangle/Future-inl.h \
-       wangle/Future.h \
-       wangle/InlineExecutor.h \
-       wangle/Later-inl.h \
-       wangle/Later.h \
-       wangle/ManualExecutor.h \
-       wangle/OpaqueCallbackShunt.h \
-       wangle/Promise-inl.h \
-       wangle/Promise.h \
-       wangle/QueuedImmediateExecutor.h \
-       wangle/ScheduledExecutor.h \
-       wangle/Try-inl.h \
-       wangle/Try.h \
-       wangle/WangleException.h \
-       wangle/detail/Core.h \
-       wangle/detail/FSM.h
+       VersionCheck.h
 
 FormatTables.cpp: build/generate_format_tables.py
-       build/generate_format_tables.py
+       $(PYTHON) build/generate_format_tables.py
 CLEANFILES += FormatTables.cpp
 
 EscapeTables.cpp: build/generate_escape_tables.py
-       build/generate_escape_tables.py
+       $(PYTHON) build/generate_escape_tables.py
 CLEANFILES += EscapeTables.cpp
 
 GroupVarintTables.cpp: build/generate_varint_tables.py
-       build/generate_varint_tables.py
+       $(PYTHON) build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybase_la_SOURCES = \
@@ -243,6 +294,7 @@ libfollybase_la_SOURCES = \
        FormatTables.cpp \
        Malloc.cpp \
        Range.cpp \
+       StringBase.cpp \
        String.cpp \
        Unicode.cpp
 
@@ -253,6 +305,11 @@ libfolly_la_SOURCES = \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
+       futures/detail/ThreadWheelTimekeeper.cpp \
+       futures/Future.cpp \
+       futures/InlineExecutor.cpp \
+       futures/ManualExecutor.cpp \
+       futures/QueuedImmediateExecutor.cpp \
        detail/Futex.cpp \
        GroupVarint.cpp \
        GroupVarintTables.cpp \
@@ -266,22 +323,26 @@ libfolly_la_SOURCES = \
        io/RecordIO.cpp \
        io/ShutdownSocketSet.cpp \
        io/async/AsyncTimeout.cpp \
+       io/async/AsyncUDPSocket.cpp \
        io/async/AsyncServerSocket.cpp \
-       io/async/AsyncSSLServerSocket.cpp \
+       io/async/AsyncSignalHandler.cpp \
        io/async/AsyncSocket.cpp \
        io/async/AsyncSSLSocket.cpp \
        io/async/EventBase.cpp \
        io/async/EventBaseManager.cpp \
        io/async/EventHandler.cpp \
-       io/async/Request.cpp \
        io/async/SSLContext.cpp \
+       io/async/ScopedEventBaseThread.cpp \
        io/async/HHWheelTimer.cpp \
+       io/async/test/TimeUtil.cpp \
        json.cpp \
        detail/MemoryIdler.cpp \
        MacAddress.cpp \
        MemoryMapping.cpp \
        Random.cpp \
        SafeAssert.cpp \
+       SharedMutex.cpp \
+       Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
        SpookyHashV2.cpp \
@@ -291,17 +352,17 @@ libfolly_la_SOURCES = \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
-       wangle/InlineExecutor.cpp \
-       wangle/ManualExecutor.cpp \
+       experimental/fibers/Baton.cpp \
+       experimental/fibers/Fiber.cpp \
+       experimental/fibers/FiberManager.cpp \
+       experimental/fibers/FiberManagerMap.cpp \
+       experimental/fibers/GuardPageAllocator.cpp \
+       experimental/fibers/TimeoutController.cpp \
+       experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
-       experimental/Singleton.cpp \
-       experimental/TestUtil.cpp \
-       experimental/wangle/concurrent/CPUThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/Codel.cpp \
-       experimental/wangle/concurrent/IOThreadPoolExecutor.cpp \
-       experimental/wangle/concurrent/ThreadPoolExecutor.cpp \
-       experimental/wangle/ConnectionManager.cpp \
-       experimental/wangle/ManagedConnection.cpp
+       experimental/JSONSchema.cpp \
+       experimental/Select64.cpp \
+       experimental/TestUtil.cpp
 
 if HAVE_LINUX
 nobase_follyinclude_HEADERS += \
@@ -311,7 +372,6 @@ libfolly_la_SOURCES += \
 endif
 
 if !HAVE_LINUX
-nobase_follyinclude_HEADERS += detail/Clock.h
 libfollybase_la_SOURCES += detail/Clock.cpp
 endif