Move Thrower into exception_wrapper
[folly.git] / folly / Makefile.am
index b353b1bfc79c1d59707ea27b5e1737784af5e3ac..0277a34171d1a4327f26f9fcb3a609b266c37d65 100644 (file)
@@ -8,6 +8,7 @@ ACLOCAL_AMFLAGS = -I m4
 
 CLEANFILES =
 
+
 noinst_PROGRAMS = generate_fingerprint_tables
 generate_fingerprint_tables_SOURCES = build/GenerateFingerprintTables.cpp
 generate_fingerprint_tables_LDADD = libfollybase.la
@@ -59,7 +60,6 @@ nobase_follyinclude_HEADERS = \
        detail/CachelinePaddedImpl.h \
        detail/ChecksumDetail.h \
        detail/DiscriminatedPtrDetail.h \
-       detail/ExceptionWrapper.h \
        detail/FileUtilDetail.h \
        detail/FingerprintPolynomial.h \
        detail/Futex.h \
@@ -107,6 +107,7 @@ nobase_follyinclude_HEADERS = \
        experimental/FunctionScheduler.h \
        experimental/FutureDAG.h \
        experimental/io/FsUtil.h \
+       experimental/JemallocNodumpAllocator.h \
        experimental/JSONSchema.h \
        experimental/LockFreeRingBuffer.h \
        experimental/NestedCommandLineApp.h \
@@ -144,6 +145,7 @@ nobase_follyinclude_HEADERS = \
        File.h \
        FileUtil.h \
        Fingerprint.h \
+       FixedString.h \
        folly-config.h \
        Foreach.h \
        FormatArg.h \
@@ -221,6 +223,7 @@ nobase_follyinclude_HEADERS = \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
+       io/async/EventBaseThread.h \
        io/async/EventFDWrapper.h \
        io/async/EventHandler.h \
        io/async/EventUtil.h \
@@ -363,6 +366,7 @@ nobase_follyinclude_HEADERS = \
        ThreadName.h \
        TimeoutQueue.h \
        TokenBucket.h \
+       tracing/StaticTracepoint.h \
        Traits.h \
        Try-inl.h \
        Try.h \
@@ -411,6 +415,7 @@ libfolly_la_SOURCES = \
        detail/IPAddress.cpp \
        dynamic.cpp \
        ExceptionWrapper.cpp \
+       Executor.cpp \
        File.cpp \
        FileUtil.cpp \
        FingerprintTables.cpp \
@@ -429,6 +434,7 @@ libfolly_la_SOURCES = \
        IPAddressV4.cpp \
        IPAddressV6.cpp \
        LifoSem.cpp \
+       init/Init.cpp \
        io/Compression.cpp \
        io/Cursor.cpp \
        io/IOBuf.cpp \
@@ -445,6 +451,7 @@ libfolly_la_SOURCES = \
        io/async/EventBase.cpp \
        io/async/EventBaseLocal.cpp \
        io/async/EventBaseManager.cpp \
+       io/async/EventBaseThread.cpp \
        io/async/EventHandler.cpp \
        io/async/Request.cpp \
        io/async/SSLContext.cpp \
@@ -483,6 +490,7 @@ libfolly_la_SOURCES = \
        portability/Unistd.cpp \
        Random.cpp \
        SafeAssert.cpp \
+       ScopeGuard.cpp \
        SharedMutex.cpp \
        Shell.cpp \
        MicroLock.cpp \
@@ -504,6 +512,7 @@ libfolly_la_SOURCES = \
        experimental/DynamicParser.cpp \
        experimental/FunctionScheduler.cpp \
        experimental/io/FsUtil.cpp \
+       experimental/JemallocNodumpAllocator.cpp \
        experimental/JSONSchema.cpp \
        experimental/NestedCommandLineApp.cpp \
        experimental/observer/detail/Core.cpp \