Moving DestructorCheck from proxygen library to folly.
[folly.git] / folly / Makefile.am
index 3d5fd9ba5816c27af5a3a18f6445d07fe098fc52..00796bb46390c88016efe9b2d38c65d16576f105 100644 (file)
@@ -58,6 +58,7 @@ nobase_follyinclude_HEADERS = \
        CppAttributes.h \
        CpuId.h \
        CPortability.h \
+       concurrency/CoreCachedSharedPtr.h \
        detail/AtomicHashUtils.h \
        detail/AtomicUnorderedMapUtils.h \
        detail/AtomicUtils.h \
@@ -104,8 +105,10 @@ nobase_follyinclude_HEADERS = \
        experimental/AtomicSharedPtr.h \
        experimental/detail/AtomicSharedPtr-detail.h \
        experimental/AutoTimer.h \
+       experimental/ThreadedRepeatingFunctionRunner.h \
        experimental/Bits.h \
        experimental/BitVectorCoding.h \
+       experimental/CodingDetail.h \
        experimental/DynamicParser.h \
        experimental/DynamicParser-inl.h \
        experimental/ExecutionObserver.h \
@@ -147,6 +150,7 @@ nobase_follyinclude_HEADERS = \
        experimental/symbolizer/StackTrace.h \
        experimental/symbolizer/Symbolizer.h \
        experimental/Select64.h \
+       experimental/StampedPtr.h \
        experimental/StringKeyedCommon.h \
        experimental/StringKeyedMap.h \
        experimental/StringKeyedSet.h \
@@ -237,6 +241,7 @@ nobase_follyinclude_HEADERS = \
        io/async/DecoratedAsyncTransportWrapper.h \
        io/async/DelayedDestructionBase.h \
        io/async/DelayedDestruction.h \
+       io/async/DestructorCheck.h \
        io/async/EventBase.h \
        io/async/EventBaseLocal.h \
        io/async/EventBaseManager.h \
@@ -246,7 +251,6 @@ nobase_follyinclude_HEADERS = \
        io/async/EventUtil.h \
        io/async/NotificationQueue.h \
        io/async/HHWheelTimer.h \
-       io/async/ssl/OpenSSLPtrTypes.h \
        io/async/ssl/OpenSSLUtils.h \
        io/async/ssl/SSLErrors.h \
        io/async/ssl/TLSDefinitions.h \
@@ -271,6 +275,7 @@ nobase_follyinclude_HEADERS = \
        io/async/test/TimeUtil.h \
        io/async/test/UndelayedDestruction.h \
        io/async/test/Util.h \
+       Iterator.h \
        json.h \
        Lazy.h \
        LifoSem.h \
@@ -291,6 +296,7 @@ nobase_follyinclude_HEADERS = \
        MPMCPipeline.h \
        MPMCQueue.h \
        Optional.h \
+       Overload.h \
        PackedSyncPtr.h \
        Padded.h \
        Partial.h \
@@ -357,6 +363,7 @@ nobase_follyinclude_HEADERS = \
        SpookyHashV2.h \
        ssl/OpenSSLCertUtils.h \
        ssl/OpenSSLHash.h \
+       ssl/OpenSSLPtrTypes.h \
        ssl/OpenSSLVersionFinder.h \
        ssl/SSLSession.h \
        ssl/detail/SSLSessionImpl.h \
@@ -393,6 +400,7 @@ nobase_follyinclude_HEADERS = \
        Try.h \
        Unicode.h \
        Function.h \
+       Functional.h \
        UncaughtExceptions.h \
        Unit.h \
        Uri.h \
@@ -414,6 +422,7 @@ GroupVarintTables.cpp: build/generate_varint_tables.py
 CLEANFILES += GroupVarintTables.cpp
 
 libfollybasesse42_la_SOURCES = \
+       detail/ChecksumDetail.cpp \
        detail/RangeSse42.cpp
 
 libfollybase_la_SOURCES = \
@@ -519,6 +528,7 @@ libfolly_la_SOURCES = \
        SharedMutex.cpp \
        Shell.cpp \
        MicroLock.cpp \
+       Optional.cpp \
        Singleton.cpp \
        SocketAddress.cpp \
        SpookyHashV1.cpp \
@@ -529,10 +539,12 @@ libfolly_la_SOURCES = \
        stats/Instantiations.cpp \
        Subprocess.cpp \
        ThreadCachedArena.cpp \
+       ThreadName.cpp \
        TimeoutQueue.cpp \
        Uri.cpp \
        Version.cpp \
        experimental/AsymmetricMemoryBarrier.cpp \
+       experimental/ThreadedRepeatingFunctionRunner.cpp \
        experimental/bser/Dump.cpp \
        experimental/bser/Load.cpp \
        experimental/DynamicParser.cpp \
@@ -607,7 +619,7 @@ libfolly_la_SOURCES += \
 endif
 
 libfollybasesse42_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)
-libfollybasesse42_la_CXXFLAGS = -msse4.2
+libfollybasesse42_la_CXXFLAGS = -msse4.2 -mpclmul
 
 libfollybase_la_LIBADD = libfollybasesse42.la
 libfollybase_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LT_VERSION)