fixed adding file problem
[c11concurrency-benchmarks.git] / gdax-orderbook-hpp / demo / dependencies / websocketpp-0.7.0 / test / random / CMakeLists.txt
diff --git a/gdax-orderbook-hpp/demo/dependencies/websocketpp-0.7.0/test/random/CMakeLists.txt b/gdax-orderbook-hpp/demo/dependencies/websocketpp-0.7.0/test/random/CMakeLists.txt
new file mode 100644 (file)
index 0000000..1fd459d
--- /dev/null
@@ -0,0 +1,17 @@
+# Test RNG policy none
+file (GLOB SOURCE none.cpp)
+
+init_target (test_random_none)
+build_test (${TARGET_NAME} ${SOURCE})
+link_boost ()
+final_target ()
+set_target_properties(${TARGET_NAME} PROPERTIES FOLDER "test")
+
+# Test RNG policy random_device
+file (GLOB SOURCE random_device.cpp)
+
+init_target (test_random_random_device)
+build_test (${TARGET_NAME} ${SOURCE})
+link_boost ()
+final_target ()
+set_target_properties(${TARGET_NAME} PROPERTIES FOLDER "test")