Rename ValueRequiresCast to ShouldOptimizeCast, to better reflect
[oota-llvm.git] / lib / Transforms / InstCombine /
drwxr-xr-x   ..
-rw-r--r-- 437 CMakeLists.txt
-rw-r--r-- 14931 InstCombine.h
-rw-r--r-- 27631 InstCombineAddSub.cpp
-rw-r--r-- 83856 InstCombineAndOrXor.cpp
-rw-r--r-- 46793 InstCombineCalls.cpp
-rw-r--r-- 55390 InstCombineCasts.cpp
-rw-r--r-- 106965 InstCombineCompares.cpp
-rw-r--r-- 23950 InstCombineLoadStoreAlloca.cpp
-rw-r--r-- 25317 InstCombineMulDivRem.cpp
-rw-r--r-- 33560 InstCombinePHI.cpp
-rw-r--r-- 25608 InstCombineSelect.cpp
-rw-r--r-- 19366 InstCombineShifts.cpp
-rw-r--r-- 46940 InstCombineSimplifyDemanded.cpp
-rw-r--r-- 23028 InstCombineVectorOps.cpp
-rw-r--r-- 3314 InstCombineWorklist.h
-rw-r--r-- 50861 InstructionCombining.cpp
-rw-r--r-- 436 Makefile